7

I am aware this might be a small/insignificant detail of the UX interface specific to The Workplace1.

However, I have noticed that the spacing between elements in the top bar (esp. your badges, rep and avatar) have different sizes when on the Users tab than when on any other tab or SE page.

If you click on Users tab after seeing any other tab (like tags, questions, etc.) you may experience a "notorious" change of layout; were the spacing between elements of the rep/badges bar seem to shrink.

This seems to happen only on TWP pages, and on users that have at least one gold, silver, and bronze badge on the site (checked with Masked Man that this didn't happened on other sites).

Could this be a minor bug? I wonder if you see the same. Seems to be strange enough for a designed feature. Already checked on Firefox and Chrome, on a New/Old computer, respectively.

gif image showing the bug

Update: Seems that the same issue is happening at Movies SE (as pointed out by Ilmari). Could it be that this is a thing in other SE sites beside these two?

Update 2: The Top Bar now has a new behavior, as it "blinks" when changing between tabs (maybe because Winter Bash?). This makes it seem like the spacing is unchanged, but comparing them after the "blink" we can see that this problem persists...

Update 3: Seems that it was indeed due to Winter Bash. Now the usual Top Bar is back and the problem persists.

1.I know it is specific as I tried it with Masked Man, on other SE networks, and it only happened here apparently.

  • 2
    Confirmed to just affect Workplace, both main and meta. Curious. Not sure the gold badge requirement is relevant though. – Lilienthal Nov 10 '17 at 7:16
  • @Lilienthal I think all 3 types are required otherwise the badges wonte take much place and not resize (I tried in other sites where I dont have all three types, aand tried with other user in other site where he had all three and it didn't happened) – DarkCygnus Nov 10 '17 at 13:18
  • Gold badge doesn't matter. I don't have a gold badge on meta, as you can see. – Masked Man Nov 10 '17 at 14:06
  • Thanks @MaskedMan ... I mean thanks Mr. Other user ;) – DarkCygnus Nov 10 '17 at 14:13
  • 2
    It's putting slightly more space between the badge groups, so probably the more groups you have the more you'll notice the cumulative effect. – Monica Cellio Nov 10 '17 at 16:41
  • Seems like so @MonicaCellio ... any news on this? Do you consider I should post this on Meta SE as well, or do we wait a bit more perhaps? – DarkCygnus Nov 10 '17 at 17:11
  • 1
    @DarkCygnus SE does monitor the "bug" tag on per-site metas, and I just added the "design" tag which might help reach the right group. It's not an urgent matter, so let's give that process time to work. – Monica Cellio Nov 10 '17 at 17:13
  • 1
    Looks like the same issue as this one on movies.SE. I suppose I could just enable the SOUP fix for that bug on all sites. – Ilmari Karonen Nov 28 '17 at 7:48
  • @IlmariKaronen Agreed, seems the same bug. I am not familiar with that plugin (seems that you are its author, cool). Do you think it will help eradicate this? – DarkCygnus Dec 1 '17 at 17:55
  • @DarkCygnus: If you install it, yes. I already enabled the fix globally in the development branch, and it seems to work fine also here on workplace.SE. I'll probably release a new stable version in a few days, too. – Ilmari Karonen Dec 1 '17 at 20:02
  • 1
    Little annoyances like this are part of the reason we're moving to a standard theme. Thanks for the report and hopefully we won't see this reverted any time soon. ;-) – Jon Ericson Nov 7 '18 at 1:08
  • Glad I could help. Don't know if this also solved the movies.se issue but mostly likely it did – DarkCygnus Nov 7 '18 at 1:25

You must log in to answer this question.

Browse other questions tagged .